openwrt将LAN口改为WAN方法

@lianst  September 16, 2017

牢骚

折腾了好几个好几个小时,终于搞好了。原因就是因为固件里面的端口序号和实际路由器后面的序号不一致,导致我的设置和物理连接对不上,这是个巨坑。


折腾需求

PS:我家里面有两条宽带,一条中国联通50M,一条中国移动50M。
折腾多WAN口(就是把LAN口改为WAN口)的主要目的是我想是默认上网走联通,部分IP(什么IP你懂的)通过静态路由走移动出去,因为移动的国际出口在香港,出国速度相对来说好一些。


折腾方法

1.依次点开-网络-交换机
连仕彤博客

2.首先要启用VLan,可以看到路由上一共有两个VLan。其中VLan1是局域网(LAN),VLan2是广域网(WAN)。我们需要做的就是把端口从VLan1中退出来加入到VLan2中。
连仕彤博客

3.我这里为了方便直接操作的配置文件,没有在图形界面点,配置文件如下:

config interface 'loopback'                                                                                                                                 
        option ifname 'lo'                                                                                                                                  
        option proto 'static'                                                                                                                               
        option ipaddr '127.0.0.1'                                                                                                                           
        option netmask '255.0.0.0'                                                                                                                          
                                                                                                                                                            
config globals 'globals'                                                                                                                                    
        option ula_prefix 'fdad:f064:9a59::/48'                                                                                                             
                                                                                                                                                            
config interface 'lan'                                                                                                                                      
        option type 'bridge'                                                                                                                                
        option ifname 'eth0.1'                                                                                                                              
        option proto 'static'                                                                                                                               
        option ipaddr '192.168.1.1'                                                                                                                         
        option netmask '255.255.255.0'                                                                                                                      
        option ip6assign '60'                                                                                                                               
                                                                                                                                                            
config device 'lan_dev'                                                                                                                                     
        option name 'eth0.1'                                                                                                                                
        option macaddr '74:7d:24:53:98:cb'                                                                                                                  
                                                                                                                                                            
config interface 'wan'                                                                                                                                      
        option ifname 'eth0.2'                                                                                                                              
        option _orig_ifname 'eth0.2'                                                                                                                        
        option _orig_bridge 'false'                                                                                                                         
        option proto 'pppoe'                                                                                                                                
        option username '051202259471'                                                                                                                      
        option password '123456'                                                                                                                            
        option ipv6 'auto'                                                                                                                                  
                                                                                                                                                            
config interface 'wan2'     //新起一个wan口,命名为wan2                                                                                                                                
        option ifname 'eth0.2'                                                                                                                              
        option proto 'dhcp'                                                                                                                                 
                                                                                                                                                            
config device 'wan_dev'                                                                                                                                     
        option name 'eth0.2'                                                                                                                                
        option macaddr '74:7d:24:53:98:cc'                                                                                                                  
                                                                                                                                                            
config interface 'wan6'                                                                                                                                     
        option ifname 'eth0.2'                                                                                                                              
        option proto 'dhcpv6'   
  
config switch         //交换机配置                                                                                                                                      
        option name 'switch0'    //交换机名字                                                                                                                        
        option reset '1'                                                                                                                                    
        option enable_vlan '1'   //开启VLAN                                                                                                                      

# 以下两个配置是关键点                                                                                                                                                            
config switch_vlan                                                                                                                                          
        option device 'switch0'                                                                                                                             
        option vlan '1'        //vlan1
        option ports '0 1 2 5 6t 7t'    //VLAN1端口                                                                                                                 
                                                                                                                                                            
config switch_vlan                                                                                                                                          
        option device 'switch0'                                                                                                                             
        option vlan '2'         //vlan2                                                                                                                            
        option ports '3 4 6t 7t'    //把你要变更的port加入到VLAN2中,并在VLAN中删除掉.                                                                                                                   
                                                                                                                                                               

这里最最最最值得说明的是配置vlan中的端口的时候是最烦的,因为这里面的端口号和你看到端口的顺序是不对应的,有的是反向顺序,而我的直接就是乱的,比如路由器后面我插的是LAN3,管理界面显示是LAN5已连接,刚开始没太注意,所以走了很多弯路。还好我聪明,用了最LOW的方法。一个个插,一个个的确认。^_^


4.以上步骤成功完成之后,可以在接口中看到已经有了一个wan2接口了,也获取到IP地址了。
连仕彤博客

5.然后我们就可以根据你的需求来配置路由了(静态路由),需要注意的是必须要起一条默认路由(8个0路由)。
连仕彤博客

6.现在配置已经完成了,我们来使用路由追踪工具来测试可以看到,我们起的路由已经生效了。至此,就算大功告成了!
连仕彤博客

连仕彤博客

折腾后记

还是得罗嗦几句,端口序号真TM是个坑(原谅我爆粗口),几乎花费了我2、3个小时。一开始都没有往这上面想,最后搞得筋疲力尽了,就用上了最LOW的方法。可没成想正是这最LOW的方法解决了事情。实验证明,不是我的问题,这个不是我的锅。


添加新评论

  1. vud

    路由器用的什么型号?

    Reply
    1. 连仕彤
      @vud

      k2p

      Reply
      1. lizhong
        @连仕彤

        K2p刷的openwrt的什么版本,我刷完后怎么没有交换机菜单呢?

        Reply
  2. 不错不错,来看看。。

    Reply
  3. 猫王

    K2p刷的openwrt的什么版本,我刷完后怎么没有交换机菜单呢?

    Reply
    1. 连仕彤
      @猫王

      你刷的版本不对吧

      Reply
  4. lizhong

    K2p刷的openwrt的什么版本,我刷完后怎么没有交换机菜单呢?

    Reply
    1. lianshitong
      @lizhong

      那得看你用过的那个版本

      Reply
  5. cuckoo

    你刷的是哪个版本的openwrt??我的K2P也没有交换机选项。

    Reply
    1. 了然
      @cuckoo

      我也遇到过这个问题,后来找到了:你刷PandoraBox就行。

      Reply